No announcement yet.

reWASD caused my Razer Orbweaver to not be recognised by Synapse

  • Filter
  • Time
  • Show
Clear All
new posts

  • Phantorang
    Yep, I have had no issue before and it works like it should now

    Leave a comment:

  • reWASDer
    Thank you very much for the details!

    Well, we have experienced issues with Windows updates and device detection. The combination of Windows updates and reWASD updates could possible went wrong.
    Great that the issue was temporary. Huge relief, yay!

    reWASD enables itself on the Windows startup by default. You may switch the autostart off from Preferences (an icon at the bottom-right of the main windows). However, if you are using it pretty often and want the configs to be applied automatically, it is better to keep the tray agent on.

    Still pretty interesting that you needed to kill reWASD before the Synapse installation. Synapse 2 is working perfectly on my PC together with reWASD but you never know what may happen. We will try to investigate the issue from our side too to find the possible reasons.

    Leave a comment:

  • Phantorang

    1. I killed reWASD from taskmanager, but I did not uninstall reWASD(its set to start when windows starts, not sure if that's a default, but that's how it works here)
    2. Install Synapse and get all the updates etc and get into the settings
    3. Start reWASD. So it was just a temporary issue, reWASD is running fine with Synapse now.

    This has not been an issue for me before, it was just something that happened, probably an update from either windows, razer or reWASD, I don't know.

    There are of course things I can't be sure of, I can't be sure if it was just enough to stop reWASD from running and then open an already installed Synapse or if I had to do as I did, install Synapse while reWASD wasn't running.
    And I can't be certain if I could just have turned reWASD remap off instead of killing the process in task manager.

    I chose to do it thoroughly, because I had spent so much time uninstalling and reinstalling with no luck, and I didn't bother to check if I could have done it differently, its very frustrating work

    I talked to razer live support and they told me to do this:

    1. Open the Task Manager and end all process related to Razer and Synapse.
    2. Open Programs and Features and uninstall Razer Synapse and Razer SDK Core Components.
    3. Restart the computer.
    4. Delete all Razer folders you can find in C:\Program Files(x86) and C:\Program Data\.
    > The Program Data folder is set to hidden by default so you might need to change the folder option first.
    Windows 10 – Open File Explorer. Click on View at the upper left of File Explorer and look for the check box that says hidden items and put a check on it.
    > A new window should pop up and under view tab, select the option to show hidden files, folders or drives.
    5. Open the Device Manager and look for the drivers of all Razer devices. To open Device Manager, press Windows + r, type in devmgmt.msc and press enter.
    6. Uninstall all of the drivers you can find for Razer devices and make sure to select the option to delete the drivers as well.
    7. Restart the computer
    8. Temporarily turn off the Windows Firewall and anti-virus program.
    9. Download the latest installer for Synapse here:,343,239 and run the installer as admin.
    10. Sign in with your account and wait for the updates to finish. Proceed with the restart after the update.

    Which I did, many times. Looked up on different ways to completely remove all residue of any razer file, nothing worked, finally killing off reWASD (again, not sure if I actually had to kill it, could possibly be enough to just exit reWASD), at that moment it felt like that was what solved it, but I still can't be 100% certain some part of the old razer driver wasn't properly uninstalled or something. I did the process so many times, that's why I chose to write this post just in case someone else had experienced problems. I found 1 other incident with the same problem as me when I was looking around for a solution, but it was only the issue, it seems he never got back to updating his post and tell if he had solved it or not, so I got no idea if it was for the same reason, just that it he had same issue with Synapse not recognizing his razer mouse.

    Synapse version
    The version of Synapse I downloaded is in bold, but razer synapse auto updates and downloads personal profiles and settings etc from the cloud, so when all is updated its Synapse

    If there is something else I can help with, I'm happy to help.
    Last edited by Phantorang; 02.05.2019, 09:37.

    Leave a comment:

  • reWASDer

    Thanks a lot for contacting us. That is a big surprise for us actually.

    Could I get more details to investigate this issue properly? The first question is what do you mean by "turn it off"? Have you uninstalled reWASD, killed its processes in the task manager or just turn the reWASD remap off?

    The second question is about Synapse. Do you use the third version for your Orbweaver?

    Leave a comment:

  • reWASD caused my Razer Orbweaver to not be recognised by Synapse

    tl;dr: reWASD software made Synapse (Razer software) unable to recognise my Orbweaver, if you got trouble with Synapse and got reWASD (or maybe something like it), try to temporarily disable it while you get razer synapse to work, then enable it again, worked for me.

    So much trouble, but so easy solution.
    3 weeks ago I couldn't get into Razer Synapse and change settings for my Orbweaver, Synapse didn't seem to detect the Orbweaver, even though it showed up on Device Manager, and the default buttons worked. But what's the point with an Orbweaver if the buttons can't be reprogrammed.

    So I tried everything, was in touch with support (they were nice and tried their best), but I just couldn't get the Orbweaver to be seen by Synapse. I installed and reinstalled several times until I gave up, took to many hours.

    But I like my Orbweaver, I got frustrated over the finger gymnastics I had to do to play certain games, so I had to do a retry.

    So I uninstalled everything, reinstalled, didn't work. Tried a bit harder, went into the registry and picked out everything with Razer in it and did a thorough search, finally everything gone, followed the instructions on how to do a clean install, disable virus software, defender and firewall, still didn't work. Frustrating.

    But then I remembered I downloaded reWASD, because I wanted to properly reprogram my Xbox Elite controller, I thought maybe if I turn that off synapse will work. And loathe and behold, it did, Finally!

    Happy ending.
    Last edited by Phantorang; 02.05.2019, 22:56.