No announcement yet.

Rewasd doesn't work?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Rewasd doesn't work?

    Hello am new to REwasd and might sound terribly stupid but i really don't see what's wrong, the software works well but when it comes to mapping nothing works, tried to map on my keyboard and same as my mouse, both doesn't work, tried to unmap, uninstall/reinstall, tried on different software : desktop, chrome, and some other games the result is still the same.

    I have no clue

  • #2
    I would appreciate if you specify some details, but first:

    1. Be sure that you select the right device where you apply the config to -

    2. Make sure that the apply button pressed and remap is on button is yellow one -

    In case these steps are good, then specify what exactly this mapping should do (in the game) and how did you create them.

    Thank you in advance.
    Don't worry! Be Happy!


    • #3
      Thanks for your answer, first am sure about the two point you made.
      Well here the two setup i tried :Click image for larger version

Name:	test2.png
Views:	2825
Size:	551.8 KB
ID:	217088
      Click image for larger version

Name:	test.png
Views:	2728
Size:	358.3 KB
ID:	217087However thanks to your screen i might have found the issue, on the screen below you'll see the controler devise list which is at the bottom left cornor of REwasd, and both of the screen i sent earlier there's still this "Logitech_LGVirHid02 which isn't my mouse or either my keyboard and it's stuck on it, maybe it's a driver or software issue i've indeed a logitech software for my mouse G502, and my keyboard is just a regular keyboard, i don't see why there's like 4 device on the list while i just own 2 device : Keyboard and Mouse


      • #4
        Click image for larger version

Name:	test3.png
Views:	2671
Size:	20.0 KB
ID:	217090here's the said last screen


        • #5

          I have no fast explanation why you see Logitech_LGVirHid02 as a separate device but it seems that it is not the one you need.

          Right now, I advise you to black-list it as far as it has no use. Right-click the yellow icon and choose Do not show in reWASD option. You will need to confirm your choice in the pop-up window too.

          Click image for larger version  Name:	620778001e.jpg Views:	0 Size:	14.5 KB ID:	217092

          You will switch to the next device in the list. I may assume that the one you have above the mysterious mouse (with keyboard and mouse icon) is your physical mouse. It has additional buttons and so they are detected as a keyboard inside a mouse. Once you choose this device (you need to click on it), you will be able to Apply config to it.

          You will need to switch between all devices in the list and black-list the ones that should not be there.

          Please give it a try and send us more screens of what you see if there are any issues.

          PS: if you want to solve the mystery of additional devices, I may guide you how to collect logs, so we could investigate it from our side Or you may just hide the ones that are not intended to be there.