No announcement yet.

PC hanging on shutdown when reWASD doesn't properly disconnect the virtual controller

  • Filter
  • Time
  • Show
Clear All
new posts

  • PC hanging on shutdown when reWASD doesn't properly disconnect the virtual controller

    Been using the default DS4 configuration for streaming play. When I click Apply Remaps, Windows makes the ascending sound it does when you plug in any new USB device, signifying the virtual controller is detected by my system.

    When I turn off remaps it's even odds Windows makes the descending sound it uses when you unplug something. If it fails to make the sound, even though reWASD says everything's switched off, when I shut down my computer it hangs on the Shutting Down message. Sometimes when I boot up after it'll hang for a minute on the spinning circle. After this it'll shut down/start up normally until I run reWASD again and it doesn't properly exit.

    I'm guessing this is Windows trying to resolve the shutdown for the virtual USB device reWASD created. Is there a way or command that'll force reWASD to deactivate everything cleanly? Thanks.

  • #2

    Apparently you apply the config that creates the virtual device, so this is the sound that a new device was added. The same thing with when you proceeding remap off - the virtual controller disables. You may open joy.cpl (type joy.cpl in Windows Search and open an appropriate app) and check a new device after config applying.

    All macros will be disabled for all devices if you press ctrl+alt+del shortcut.

    What do you mean it hangs on the Shutting Down message? What exactly hangs? Please open event viewer - Window Log - System and check whether there are error events relate to the reWAD? I would appreciate it if you describe specific steps leading to the problem.

    Also, please check if fast startup option is checked
    Don't worry! Be Happy!


    • #3

      Start reWASD
      Click Options -> PS4 Remote Play
      Click For Keyboard & Mouse config
      Click Apply (device detected sound plays)

      Later on, click Remap is ON to toggle it off. Ideally the device unplugged sound plays. If it doesn't if you turn Remap back on the controller won't be created. Restarting reWASD has no effect. Unplugging and replugging the physical 360 controller has no effect.

      If you go to Device Manager and try and uninstall the controller it stays on an infinitely scrolling Uninstalling Device... progress bar that can only be exited via Task Manager

      I have verbose start-up/shutdown switched on so rather than the usual Shutting Down message it tells you all the services it's stopping and then at the very end goes back to Shutting Down... before switching off. My PC reaches this step but never shuts down.

      Fast startup is disabled.


      • #4
        Thank you for your steps.

        Please, open joy.cpl. Then apply the config. You will see that the new virtual controller is added (Xbox 360 for Windows) - (wireless gamepad is my Switch pro connected). Then you press remap is ON yellow button you cancel mappings and the virtual controller disappears from as well. So, do you still have the virtual controller after you switch the mapping off?

        Do you use the PS4 Remote Play to make a DS4 gamepad from your Xbox 360? What drivers\controller did you try to remove via Task Manager? Have you checked the Event Viewer regarding system errors?

        "It tells you all the services it's stopping and then at the very end goes back to Shutting Down" - please open Services and find gamepad control mapping service, stop it and try to shut down the PC - Will the problem be the same?
        Don't worry! Be Happy!


        • #5
          Yes, when activated the X360 Controller in joy.cpl is replaced with Wireless Controller due to the default Hide Physical Controller option. If it fails to shutdown properly the Wireless entry remains.

          I tried ending tasks for anything related to reWASD, X360 and anything that looked out of sorts. Ending gamepad control mapping service from task manager doesn't change anything, including hanging on shutdown. 360 drivers are version 10.0.18362.1 and Windows Updates claims they are the latest.

          Event Log shows nothing except for errors due to sudden loss of power due to me having to shut it down by holding the power button.


          • #6

            I still do not understand what controller did you uninstall in the Device Manager, your controller, or reWASD one. When remap is ON your physical device is hidden, the virtual controller is active. When remap is OFF only physically connected device (which is your Xbox gamepad) is detected, means that reWASD is inactive and doesn't affect the system.

            So, does the problem remain if you do remap off, check the joy.cpl to see only your physical device, proceed PC shutdown? Does the problem persist after a regular reboot? Like reboot the PC and try to shutdown.
            Don't worry! Be Happy!


            • #7
              Sorry, so this is the device when Remap is off:
              Click image for larger version

Name:	Untitled.jpg
Views:	855
Size:	26.4 KB
ID:	219781

              This is the device when Remap is on:
              Click image for larger version

Name:	Untitled2.jpg
Views:	799
Size:	26.1 KB
ID:	219782

              ‚ÄčIf Remap successfully turns off it reverts to the first image.

              When it doesn't it stays like the second image. When this happens no software action, service termination, or uninstall, including unplugging and plugging the physical controller, will change the entry. This is the case where it will hang on system shutdown if I try to turn off my PC via the Start menu. Only restarting the computer by holding down the power button will fix it and then it goes back to being the first image.


              • #8
                Thanks for the details!

                Could I ask you to collect some logs for us? All the steps are described here.

                There are two types of logs, and it is better to collect both. Tray agent logs are not required (only app).

                Please try to log the moment when remap doesn't go off. So, start logging, apply a config (you will see that wireless controller appeared), then try to turn remap off. If it doesn't go off, then stop logging and send the files to us (you can attach here). If remap goes off, repeat the steps again until you get this issue.


                • #9
                  Attached the trace logs.

                  turn on driver and turn on GUI & service are the logs for when I activated the Remap and had the logging running for about 10 mins.

                  turn off is when I switched off the remapping after ~60 mins of gaming.

                  8:55pm is when I tried to turn off remapping.
                  Attached Files


                  • #10
                    Hi, I have a similar issue.

                    My situation is different though. I use a mayflash ns to use a pS3 Navigation controller with my pc.

                    Everything works fine (nav controller is detected as a 360 controller), is wireless and fantastic.

                    However my PC also hangs on close or restart. Even if i exit rewasd prior to shutdown.

                    However I found if i exit Rewasd, then go into task manager, I see that "game controller mapping service" (reWASDService.exe) is still running.

                    If I end that task I can Shut down or Restart without any problem.

                    I hope this helps


                    • #11

                      temp89, thank you for the logs, will investigate it and I back with updates.

                      Pratator Is virtual controller (Xbox 360) still active? Does the problem persist if you turn remap OFF(not just close reWASD windows, but disable the virtual controller that the system sees only your physical controller)?
                      Don't worry! Be Happy!


                      • #12
                        Originally Posted by temp89 View Post

                        8:55pm is when I tried to turn off remapping.
                        Hey there! We have checked the logs, but nothing suspicions is there. The virtual device was removed, and your controller works as normal.
                        I have only one idea at the moment. Maybe your game somehow "remembers" the virtual controller and that is why it hangs on shut down? Could you please ensure that you have closed the games and launchers (all of them) before you shut down?


                        • #13

                          The virtual 360 controller still remains even after remap is turned off.

                          When I check joy.cpl, the virtual 360 controller is still there and the pc hangs on restart or shutdown.

                          However, the pc can reboot or shutdown if I manually close the "game controller mapping service".

                          After I have manually ended the task "game controller mapping service", the controller shows as "Controller (MAGIC-NS).


                          • #14

                            So, when remap is OFF you still have the same XBOX 360 fo Windows controller displaying in joy.cpl as when remap is ON? Does the controller is displayed in joy.cpl if you discounted the physical controller?

                            In this case, would appreciate it if you collect the logs:

                            - Unplug all connected controllers
                            - Open reWASD via Administrator. Open Preferences - StartLog
                            - Plug the device via myflsah adapter and apply the config with virtual Xbox 360 (remap ON).
                            - Do remap OFF to remove the virtual controller. Open Preferences again and press Stop Log.
                            - Attach logs with the reply.

                            Thank you in advance.
                            Don't worry! Be Happy!


                            • #15

                              The controller I am using is a PS3 Navigation Controller.

                              I am using it wirelessly.

                              I still have the same XBOX 360 for Windows controller displaying in joy.cpl, with Remap on or off (following Remap being turned on initially).

                              I will organise the logs on my next day off.

                              Thanks for your help.