Announcement

Collapse
No announcement yet.

PS4 Touchpad bindings on keyboard not working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PS4 Touchpad bindings on keyboard not working.

    I am trying to use your app to play PS Now games on my PC without a PS4 controller. The other buttons work just fine on the keyboard, but none of the touchpad binds do anything. This ability to bind the PS4 touchpad to keyboard keys is the sole reason for my interest in ReWASD. Left touchpad click and right touchpad click are required for PS2 games on the PS Now library. I am using version 5.4.0 of ReWASD.

  • #2
    Hello!

    We are aware of this issue. It is connected to PS2 games only, and we are already working on it. The fix is coming soon, in reWASD 5.5.
    Sorry for the inconvenience and stay tuned!

    Comment


    • #3
      Any rough estimate when that update might come?

      Comment


      • #4
        This summer for sure.

        Comment


        • #5
          Hello! We have released reWASD 5.5, and the issue is solved. Please check the new version :satisfied: Hope to get any feedback from you.

          The full changelog is here: https://forum.rewasd.com/forum/rewas...-and-many-more

          Comment


          • #6
            This did not fix the issue for me. The tap left/right binding still does nothing for the ps2 games on the PS Now app. I also tested swipe left/right just to see if they would work as an alternative. They did not. I also tested the touch pad mappings on The Elder Scrolls Online on PS Now. None of the touchpad bindings worked on that game either. It seems like touchpad bindings just don't work at all for PS Now. At least I haven't found a game that they work on.

            Comment


            • #7
              My previous post is unapproved so I can't edit it yet so sorry for the double post. I just discovered the update did "technically" fix the issue, it's just a bit janky. In order to get the touchpad function working I had to bind both the "touchpad" mapping and the touchpad button I wanted to use. So you need to use either the key combo feature or you need to map touchpad and the touchpad function you want to use to separate buttons. While this is less than ideal, it does work.

              Comment


              • #8
                Ok so I deleted my keyboard bindings since I'm using a gamepad (switch pro controller) and now it's NOT working anymore. And now I can't seem to figure out how to get it working again. The other controls still work but I can't seem to get the touchpad to work again. I should note when it was working I was using the switch pro controller. I've spent a few hours trying to get it working again and I'm frustrated as hell at this point.

                Comment


                • #9
                  Hello,

                  1. This is the correct behavior. In case the game requires beside tap a click, use tap+click combination. Yes, it's required to use the Combo feature. What combos are possible to make you may find this link.

                  2. Does the problem only with touchpad emulation? Do other mappings work fine? How do you try to emulate mappings?

                  Thank you in advance.
                  Don't worry! Be Happy!

                  Comment


                  • #10
                    Only touchpad emulation. Other mappings work perfectly fine. As I stated I did get it working briefly, but now it does not work no matter which configuration I try.

                    Here is what I've tried:
                    Click image for larger version

Name:	9tlSOzm.png
Views:	620
Size:	117.0 KB
ID:	221035

                    Click image for larger version

Name:	AB1KUJX.png
Views:	578
Size:	124.4 KB
ID:	221036

                    Click image for larger version

Name:	qZK81AY.png
Views:	563
Size:	102.2 KB
ID:	221037

                    The configuration in the last 2 images are the ones I got working before I deleted the keyboard configs and it stopped working. Note I have also tried using the unmap function as well as mapping these inputs to individual buttons and pressing them at the same time.

                    Comment


                    • #11
                      Hello,
                      Strange, may I ask what game is that you play where problem is caused? We will definitely check.

                      Also, what config do you use? Please, share the config as well.

                      Thank you I advance.
                      Don't worry! Be Happy!

                      Comment

                      Working...
                      X