Announcement

Collapse
No announcement yet.

Switch Pro Controller immediately switches off after "Switch to Xbox 360".

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Switch Pro Controller immediately switches off after "Switch to Xbox 360".

    Whenever I try and change it to a 360 controller (for easier compatibility with games) "Switch to Xbox 360" feature, the controller turns off shortly after I click apply. This also means that I cannot revert back since if I turn the controller on while reWASD is open is immediately switches off and is no longer detected by the software.

    Any ideas?

    Thanks.

  • #2
    Hello,

    How do you connect your Switch Pro? reWASD doesn't turn the controller off (I mean power off). It hides a physical controller and creates a virtual 360. If the game or apps has detected the physical controller, but couldn't re-detect the virtual one, I recommend to restart the software or app. Or create a virtual controller before the game (app) is launched.
    Don't worry! Be Happy!

    Comment


    • #3
      Thanks for the reply. It's a PowerA pro controller so it connects via bluetooth. I haven't launched any app or game, the device drops out of Windows when I enable 360 mode.

      Comment


      • #4
        Hello,

        But you still able to use the created 360 gamepad, like sticks, buttons are working when you press them on your PowerA, right? So, the BT connection is active.

        The power A is displayed as wireless controller joy.cpl (to open it please type joy.cpl in Windows Search). When you press the apply button with Xbox 360 config, the physical controller is hidden in the system and replaced to the virtual Xbox controller (you see Xbox 360 for Windows in joy.cpl). But, it's still in the system.

        In case you need both controllers in the system you may uncheck this option in the software preferences. But, it could bring some collisions with games as 2 controllers are connected and could be detected by games unproperly.
        Don't worry! Be Happy!

        Comment


        • #5
          No the controller completely disappears when I apply the changes. You can see what happens here:

          https://youtu.be/_eceGC-ikCE

          Comment


          • #6
            Hello,

            Please, update your current version to the latest 5.5.1 that was released yesterday. Reboot the PC, try to reproduce the problem.
            Don't worry! Be Happy!

            Comment


            • #7
              Updated and same issue as shown in video occurs after reboot with 5.5.1.

              Comment


              • #8
                Hello,

                1. Open Settings - > General - > Clear data. Re-initialize the controller again. Try to reproduce the problem. If the problem is actual - >

                2. It could happen if you have specific settings in other mappers devoted to DS4: InputMapper, DS4Win, etc.You can learn more about this issue here. Also, make sure that you do not have any third-party drives that these mappers are used (hidguardian, vigem). If the problem persists - >

                3. Close reWASD and open via Administrator privileges - > General - > Start Log. Reproduce the problem - > Back to the General tab again and Press StopLog. Attached the archive with your reply that we could check the details.

                4. Also, please attach the msinfo32 file
                Don't worry! Be Happy!

                Comment


                • #9
                  Thanks for the reply.

                  1. No change
                  2. The reinstall of windows was fresh and it was happening immediately.
                  3. Attached
                  4. Attached (zipped to fit below 2MB limit)

                  Cheers!
                  Attached Files

                  Comment


                  • #10
                    Hello,
                    Thank you for the logs. Please, open preferences -> LED settings - > select Nintendo controllers from drop-down menu and disable all options. Apply changes and try to reproduce the problem.


                    Let us know any results.
                    Don't worry! Be Happy!

                    Comment


                    • #11
                      Go to Settings -> LED Settings and then select Ninendo controllers from the drop-down and uncheck "Prevent other apps from using the LED." The "use LED for active slot" works just fine.

                      Comment


                      • #12
                        Originally Posted by CriticalComposer View Post
                        Go to Settings -> LED Settings and then select Ninendo controllers from the drop-down and uncheck "Prevent other apps from using the LED." The "use LED for active slot" works just fine.
                        I can confirm unticking that one box fixed my issue. Thanks Star-Lord and CriticalComposer!

                        Comment


                        • #13
                          Hello,

                          Thank you for your feedback. We also have a PowerA controller and experienced the same behavior. It will be fixed with the next release.

                          Sorry for the inconvenience.
                          Don't worry! Be Happy!

                          Comment

                          Working...
                          X