No announcement yet.

Change in Autodetect and Slot Switching Behavior

  • Filter
  • Time
  • Show
Clear All
new posts

  • Change in Autodetect and Slot Switching Behavior

    I'm using an XBox Elite Series 2 controller. Up until recently, if I was using an autodetect profile while playing a game, after I exit the game, reWASD would revert back to the previous config that was manually applied to a particular slot, which was perfect for my setup. All of a sudden, exiting a game causes the slot to be wiped completely of a config. I'm not sure what changed on my computer to cause this, but what is the actual intended behavior when exiting a game, and if it's not the former, could you add it as a feature?

    Also, at the same time this happened, there was a change in the way the profile button on the controller worked. Previously, holding down the button would cause reWASD to jump back to slot 1, just like how the default XBox Accessories profiles work. Now, holding down the button does nothing in reWASD, even though the light on the controller still indicates that the first slot is selected.

    There have been no updates to reWASD on my PC since these changes have appeared to happen (I'm on 5.5.1). I did apply the new Windows 10 Fall Update - not sure that that might have caused this. Any ideas?

  • #2

    Autodetect has never worked the way you describe in reWASD. We have an option in Preferences — "Remove applied config on exit from the associated app", — but it doesn't switch you back to the manually applied config, it just removes the one that was active with Autodetect.

    I think I know how you got the previous behavior. If you associate an app with Slot 1, but manually apply something to Slot 2, then, after the config is removed from Slot 1, you will get back to the first available slot with a config — number two. This is what you can do know, and I would ask you to try it. Here is a video that describes the steps, I've associated config 1 with my browser:

    As for the slot thing, reWASD changes the slots when you change them using that button. Each new press directs you to the next slot. Please note that Slot 1 in reWASD is Slot 0 on the controller. Nothing could change here, so I would ask you to do two things:

    1. Fresh restart of data:
    1. Go to Preferences (a gear icon at the bottom right), General tab
    2. Click Clear data button and confirm your action
    3. Wait until the GUI and tray agent appear
    4. Adjust your Autodetect and manual configs to proper slots

    2. Re-check to which slot the manual config is applied. Please note that in order it to work like you need, you should have different slots for Autodetect and a manual config.


    • #3
      Thank you for the quick response!

      Your suggestion of assigning the autodetect config to an empty slot did the trick! That's what I must have done previously and not realized, as it's working exactly the way it used to.

      Regarding the slot thing, clearing the data in preferences didn't fix it. However, while further testing, I did notice something. If I have a slot selected with no config assigned and I hold down the button, it correctly selects the config in slot 1 of reWASD/slot 0 on the controller as expected. If I have a slot selected that does have a config assigned and I hold down the button, the dropdown control on the top-left of reWASD jumps back to slot 1, but the radio buttons on the bottom of reWASD stays where it is and the config doesn't change to slot 1.


      • #4
        Great that the first part worked! :satisfied:

        As for a slot switcher, I am not sure why you say "hold" it. The button works as a toggle, that goes from null to the third slot. Each new press switch the slot on the controller, and you may see how the lines under the switcher mark the active config (let me remind that when there are no lines, it is Slot 0 or Slot 1 in reWASD).

        We do work with a switcher, but also, reWASD could switch its slots by other activators. For example, in reWASD you have chosen Slot 2 as an active slot (just pressed the needed dot). At the moment, on your controller, physically, you can see no lines under the slot switcher — Slot 0. If you now use the switcher, it will show you one line that is equal to Slot 1 on the controller or Slot 2 for reWASD. But, you have already chosen it in the GUI, and so there is no switching at the moment. You will need to make a full circle (four presses) to get back. Otherwise, you can try our hotkeys that also switch slots without this button at all.


        • #5
          I'm struggling to find Microsoft's official documentation about the "hold" functionality, but it is described in the review here, in the second paragraph of the Xbox Accessories App section:

          Using the standalone app, if you hold down the profile button, regardless of which slot is currently selected, it jumps back to the default profile, which presumably would be slot 0, and the LED shows no lines. This prevents you from having to make a full circle to get back. It appears to at least partially work in reWASD as I previously described, but if you were unaware of this hardware feature, that could be why. I can certainly live without this working as it does using the native app, especially now that autodetect appears to work again how I want it to, but I thought you might want to be aware of this seemingly undocumented functionality. I appreciate your help!


          • #6
            Thank you for the info, got it. Will check this case to find out what may happen here.
            Well, live and learn


            • #7

              We have released new reWASD version that is able to switch to Slot 0 when you press and hold the hardware switcher on your Xbox Elite 2 controller.

              Thanks a lot for pointing us to this thing