No announcement yet.

Problems activating license. - ReWASD

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems activating license. - ReWASD

    Hi, I don't know if this topic goes here, excuse me if it isn't, I have a problem installing ReWASD, I bought a license yesterday, but when running the program I get a screen that says "License hasn´t been activated properly" and just two buttons that say "Retry" (which is useless) and "Close", I can't even use it in "try" mode, that window won't let me go any further, any solution?

    Click image for larger version

Name:	Captura de pantalla (644).png
Views:	1272
Size:	158.0 KB
ID:	222183

  • #2

    It seems that the internet problem. May I ask you to follow these steps:

    — please go to C:\Windows\System32\drivers\etc and open the file hosts via notepad. Please take a screenshot of the file.
    — open the command line and type ping to know if our server is pinging by your PC.

    Thank you in advance.
    Don't worry! Be Happy!


    • #3
      hi, thank you very much in advance, here are the screenshots, typing the command line "ping" the text tells me that the ping request could not be found.Click image for larger version

Name:	Captura de pantalla (653).png
Views:	1188
Size:	302.9 KB
ID:	222191
      Attached Files


      • #4
        Hi there,

        Please, remove the highlighted string in the hosts file, save changes, and try again. It will solve the activation issue.
        Don't worry! Be Happy!


        • #5
          It worked! Thank you so much man! I love you!


          • #6
            Hi there,

            Good news! Great that it worked. How a great gaming experience.
            Don't worry! Be Happy!


            • #7
              Hello, I'm having trouble installing ReWASD, I want to use the free license, but when I run the program, I get a screen that says "License hasn't been activated properly" and only two buttons say "Retry" (which is useless is) and "Close", I can't even use it in "try" mode, that window won't let me go any further, is there any solution?Click image for larger version

Name:	44.png
Views:	371
Size:	43.0 KB
ID:	236989
              Attached Files


              • #8
                MY HOSTS FILEClick image for larger version

Name:	33.png
Views:	373
Size:	29.4 KB
ID:	236991


                • #9
                  Hi. This message appears when our app cannot contact our server ( for license verification or cannot communicate with its service.

                  reWASD.exe, reWASDEngine.exe, and reWASDService.exe processes should have access to the Loopback Interface (, the Local Network (192.168.0.* by default), and Internet (or at least to to work properly.
                  If you are using Windows Firewall, ensure all reWASD rules are enabled for all network types.
                  If you use third-party anti-virus or protection software, try adding all reWASD executables to the exclusions or trusted apps list.

                  If you use an Eero Security service on your router, please allow the domain in its settings or disable the service.

                  To check the availability of our license verification server, do the following:
                  1. Run the ping command. It should resolve as, and all packets must reach their destination.
                  2. Open the link in a Chrome-based browser. If everything is normal, it should redirect you to our homepage. If it does not, send us a screenshot of the page or error you see instead.
                  If your PC cannot make a stable connection to our server, we suggest using a VPN service or contacting your Internet provider for further assistance.