No announcement yet.

Furthur Troubleshooting with dropping all virtual input for mouse and keyboard input

  • Filter
  • Time
  • Show
Clear All
new posts

  • Furthur Troubleshooting with dropping all virtual input for mouse and keyboard input

    I started doing some troubleshooting on the topic linked in the attachment below. Moving away from this post as what I am doing has nothing to do with the topic.

    The last mention in trial and error for the issue that I am having, stated in forum posts in the link below.

    "In your config, you are using both a virtual controller and keyboard mappings. I think the game switches between inputs and this may cause a significant delay.

    I would suggest you remove all virtual controller mappings (on paddles and d-pad) and remap all other controls to the corresponding mouse-keyboard actions and add "Unmap All". "

    I am trying to use WASD instead of virtual stick input to mitigate the input delay, the first red flag I am noticing is the lack of being able to gradually walk and it just being full-on as if the stick was pressed all the way forward at all times lacking the minor but significant layer to having the most control, and the movement is very jagged and not fluid at all. Is there a way to make keyboard input feel more similar to virtual joystick input? I have this same issue with the right stick used for camera movement, keyboard keys just don't have the same feel as the virtual controller input, leaving me feeling like I have less control over my characters speed/movement and camera speed/ movement in the process. This also makes the movement of both the left and right stick feel more rigid in-game having a sharper and more rigid feeling and overall less desirable. have messed with it a bit and can't figure it out for the life of me.

    To clarify this game was always intended to be played with a controller and lacks mouse support so all camera movement if not done with a controller is bound to Shift + Arrow keys.

    With all that said, I tried going on a mission and testing the delay, I tried with the long press for turbo as that how I intend the controller to end up. I still had delayed, so I removed all long press mappings and went with only start press mappings on the face button. All to no avail, there is still a terrible delay and overall inconsistency, and many ignored button presses altogether.

    I included my mapping below with my last test layout which was without a long press mapping. I am starting to wonder if ReWASD is sadly just not compatible with Phantasy Star Universe.
    Attached Files

  • #2
    Phantasy Star Universe is an old game (over 14 years old). Probably have its quirks and limitations. If there is an option to disable Vsync, you should disable it, as delay and input loss are most likely related to that. Don't forget to enable [Remap] before starting the game, and restart the game every time when you apply any changes that lead to our virtual gamepad reconnecting (a windows "new/removed device" sound is played).

    If you want to keep analogue controls you have to map sticks to a virtual gamepad. "Switching between gamepad and keyboard" delay is most likely not the issue here.

    You should check if there is a noticeable delay or input loss while reWASD`s Remap is enabled with joy.cpl and Gamepad Tester. If there is none - the game is the culprit and there isn't much we can do about it.


    • #3
      I will try disabling Vsync, would that be something specific to ReWASD causing this input delay trouble? I ask as JoytoKey does not have any kind of input delay what so ever. I hate to keep bringing them up as I appreciate their program is entirely different. I much prefer ReWASD design and it is more intuitive than JoytoKey and easier to quickly navigate and understand, though ReWASD contains a high level of nuance beyond my understanding at this time. I have been currently using ReWASD in tandem with JoytoKey and AHK as I was using the combination of JoytoKey and AHK prior to purchasing ReWASD but I wanted the chatpad support. I would like to dwindle this down into one program for convenience sake, so I am hoping with the team's help I can figure out what's causing these hiccups.

      Thank you for your time.


      • #4
        Originally Posted by Enraged Potato View Post
        I will try disabling Vsync, would that be something specific to ReWASD causing this input delay trouble?
        Disabling Vsync will allow the game to tick as fast as possible, so it probably won't miss any inputs and react to them right away, unless it has a hardcoded limit of 30 fps, which many ports of old console games do. JoytoKey and AHK are probably sending keyboard/mouse inputs directly (not sure if they create virtual devices to do that), while reWASD creates and uses virtual keyboard, virtual mouse and virtual gamepad when required.

        Having more than one remapper in the system is not recommended as they will most likely interfere with each other. If you can completely disable or uninstall other remappers, try doing that too.

        With that I'm out of ideas.