Announcement

Collapse
No announcement yet.

Help with LED settings not applying

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with LED settings not applying

    Hi! I've been using the program for quite a while, but I still have no idea how the LED setting work within specific configs.
    I run a standard Windows Home x64 license laptop.

    I did try googling and the official documentation, but nothing actually worked, nor I found some specific information I was looking for.

    I use PS4 and Dualsense controllers, both support custom LED settings, but they simply do not work. With that I mean, I change settings inside any CONFIG file, and they just don't apply to the controller. There's only ONE that works, I'll show below.

    Just to clarify, within the settings/preferences for reWASD, I did make changes specifically for the Dualsense controller, and they did work. And I am aware that the LED settings in any config it's basically a behaviour override from the default one's, configured in the software settings/preferences.

    This is how it looks like in the 'default' settings:

    Click image for larger version

Name:	Preferences.png
Views:	155
Size:	40.6 KB
ID:	226576
    I've only changed the default 'Shift 0 Modifier' to a blue hue, and it works in everyconfig file I have.



    Then, I try changing it to a green hue when using it to emulate XInput devices (Xbox controllers, basically) and this is how it looks like:

    Click image for larger version

Name:	Xinput.png
Views:	51
Size:	572.6 KB
ID:	226577
    Just to clarify the obvious here, I did try saving, applying, saving and applying, switching configs, reconnecting the device and even switching devices. Nothing worked. When I open the same screen, the LED setting ARE SAVED, I do not need to put the green hue in there again. It's just not working/applying.


    With that said, I do have ONE config file forthe Dualsense that does work, and there's only one key difference that I can't seem to find a way to "implement" it to other configurations.
    This is the config file for my Genshin Impact controller layout, I use it to be able to use the "interact action" on the touchpad click and allow gyroscope aiming, simple stuff.

    Click image for larger version

Name:	GI.png
Views:	54
Size:	599.6 KB
ID:	226578

    The major difference in this config file is that ,as far as I can remeber, this specific config file was the wone created when I added the "Dualsense" profile, in the upper right corner drop down menu. And since it was created, the LED settings button is actually colored, while any other configuration I make inside this profile gets a monochromatic grayscale icon. This also stands true to any other profile I create, for any device. The first config file has a colored icon, while any other gets a gray icon.

    Click image for larger version

Name:	Icon.png
Views:	35
Size:	17.3 KB
ID:	226579

    After doing some Googling, reading the official documentation, reading this post, I couldn't find any specific information about this. Only generics "How to" tutorials with obvious content for my personal understanding. Nothing about some kind of troubleshooting, or if I am doing something wrong, which I don't feel like I am disregarding the icon coloring, hence why this post asking for help.

    It's also completely possible I totally missed the text in any of this pages I mentioned (heck, I could have missed anywhere and everywhere) containing a possible solution, not the brightest person here. If that's the case, my bad ¯\_(ツ)_/¯

    Any help is appreciated, I think I provided all the visual and teorical info needed, but if more is necessary, I'll gladly provide.
    Attached Files

  • #2
    Hello!

    There are two things that should be set inside the config for LED: the color and the mode.

    In your XInput config, there are needed colors, but you haven't set the mode (it is None as far as I can see on the screenshot). Please set it to Solid Glow (if you want LED to have a simple light) or any other mode you like (the LED will be blinking, glowing and so on). Then, it should work as expected.

    Comment


    • #3
      Man, I can't stop laughing at my own stupidity. It was literally in my face. I feel like a total idiot. How could I not notice it even after taking the screen shots, and worse, this whole time tweaking within it? Anyway...

      Thanks a lot!

      That was the problem, aparently I can't see lol

      Comment


      • #4
        No problem, that's why we are here. reWASD has lots of various options, settings and mappings, it is totally OK if you have missed something. No worries

        Comment

        Working...
        X