No announcement yet.

rewasd crashing after a few seconds help

  • Filter
  • Time
  • Show
Clear All
new posts

  • rewasd crashing after a few seconds help


    Got a problem with my rewasd and it crashing when i open it, in task manager i can see rewasdengine running fine but rewasd itself after a few seconds stops.
    controller is xbox elite version 2 laptop is pretty new and os is windows 11.

    Attached Files

  • #2
    Hey there!

    Sometimes a color profile assigned to your display(s) can be corrupted and cause .NET to crash and stop anything from working. Please try temporarily changing the Device profile and Viewing conditions profile options to use System default from the dropdown list in Color Management → Advanced → Windows Color System Defaults and try launching reWASD again.


    • #3
      I have tried them all one by one and none of them works, any other suggestions ?


      • #4

        Please open this folder: C:\ProgramData\Disc-Soft\reWASD

        You will see several *.binv2 files there. Copy them and send to us for the investigation. Then please remove all *.binv2 files and try to launch the app again.


        • #5

          I had to rename it to txt to have it upload, but i removed them and still same issue.
          Attached Files


          • #6
            Thank you for the details. We will need some time to re-check those ones with the team. In the meantime, could you please try to collect more logs for us, so we could check this case from different sides? Here are the steps:
            1. Make sure you have a shortcut for reWASD.exe
            2. Right-click on the needed shortcut, open Properties
            3. Find the Target field, and add " -tracetext" to it. This is how it must look like:

            4. Press OK to close Properties, and launch reWASD using the modified shortcut
            5. Now open File explorer, and go to C:\Users\Public\Documents\reWASD\Logs and send the newest reWASD TextTrace.txt file to us


            • #7
              Here you go
              Attached Files


              • #8
                Thank you, it does contain more information.

                Please try to open this folder: C:\Windows\Microsoft.NET\assembly\GAC_MSIL and find newtonsoft.Json.dll file inside (it may be a chance that you have Newtonsoft.Json folder inside this directory, it is the perfect match). Remove this file and try to launch reWASD again.


                • #9
                  That was it ! now it works. thanks alot. Do i have to delete this file regularly or something ?


                  • #10
                    Yay, great to know

                    Frankly speaking, I am not sure why this dll is not loaded normally, because this one is not created by our team — it is a library that allows working with json format we use for the config files. According to your logs, this dll was faulting, and so once you remove it, we could load the one with the correct version that worked. It may happen again, because I suppose some other apps also use this one and may re-create it again. If it happens again, please try to remove it one more time. If you understand which app uses it, you may need to update that app.


                    • #11
                      Hi again rewasder

                      Do you have any suggestion to how I can find the app that does this, as far as i can see and i have tested this a couple of times, its rewasd that creates the bad boy json.
                      I quit every other app, and only ran rewasd. First it launches (with json deleted), then Json gets created, and if i try to relaunch rewasd without deleting json it cant anymore.

                      Before getting this new laptop ive had rewasd working fine without problems on the old laptop, when the update which introduced the android app launched i began having problems like this with rewasd.


                      • #12
                        Unfortunately, we are not sure which app could do it (it is a pretty common library that could be used by many different applications). We are trying to find the solutions from our side, but I can't suggest any fast results. You could try to install the older versions but I am pretty sure that it won't help, even without crash, you will be getting errors when you try to open the config.

                        I would be grateful if you could share the exact path where you find the faulting dll and send us this one, the one that is created and prevents reWASD from launching. I hope it may help to solve the issue from our side.


                        • #13
                          Filepath is
                          C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Newtons oft.Json\v4.0_12.0.0.0__30ad4fe6b2a6aeed


                          • #14
                            Got it, thank you. Seems to be a system directory. We are trying different possible solutions right now, and I hope we could create a custom build for you (approximately in a few days). Would be cool if you could check it for us. May I contact you back here in DM once we are ready?


                            • #15
                              Sure, i'll be happy to help anyway i can. thank you.