Announcement

Collapse
No announcement yet.

Switch Pro controller not working after shutdown.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Switch Pro controller not working after shutdown.

    Switch Pro controller not working after shutdown. Remap is applied. Virtual gamepad shows in Windows Game Controller list, but no buttons work. Reapplying remap does not work. Solution is to physically disconnect and reconnect the USB cable -OR- tap the Sync button.

    Automatically connects just fine after Windows REBOOT, but not after a SHUTDOWN.


    EDIT: issue resolved as of v6.1.0
    Last edited by AnalRacoon; 03.03.2022, 06:15.

  • #2
    Hello!

    Could you please try to check if the same happens if you do not use the virtual controller and do not apply anything before the shutdown?

    I mean turn Remap OFF, turn your PC off, then start your PC again and check if your controller is registered properly in joy.cpl (the native system tool for gamepads, to open it, type joy.cpl in Windows search, click on your controller and press Properties)? Do the buttons respond properly after the new start without the necessity to re-plug the controller?

    Comment


    • #3
      Remap OFF. Control panel shows "Pro Controller" (not Xbox360/One). Buttons working.
      Shut down.
      Turned on. Control panel shows "Pro Controller". No buttons working.
      Unplug and reconnect, buttons work. LED flashes as configured to do in reWASD.

      This only happens with a fast startup (system power options) or waking up from sleep.
      Everything works fine with a full "cold" startup or reboot, but that takes 10x longer.

      Comment


      • #4
        Thank you!

        If it happens without the turned remap, it seems to be the controller issue.

        May I ask you to check the same with uninstalled reWASD (do not forget to reboot your PC after the uninstallation). Does the same happen?

        Comment


        • #5
          Please disregard my previous post — I've completely forgot that without reWASD, you won't be able to check Switch Pro in joy.cpl, as it won't be detected properly, sorry.

          I'm afraid it is a controller issue — when you shut down your PC, it actually goes to hibernate mode, similar to sleep mode. In this case, the USB port may also sleep, and after you start your PC, the system doesn't recognize this port, and it should be refreshed. Once you re-plug the controller, everything goes back to the normal state.

          I have one more suggestion for you though:

          1. In Device Manager, choose View by connection view
          2. Find your controller and navigate to USB Input Device
          3. Check if it has Power Management tab in Properties
          4. Uncheck Allow the computer to turn off this device to save power

          Click image for larger version

Name:	481180d813.png
Views:	359
Size:	242.0 KB
ID:	229420

          Comment


          • #6
            Click image for larger version

Name:	NotThere.png
Views:	323
Size:	30.6 KB
ID:	229424
            Doesn't seem to be there. I tried adjusting that mystery "USB Input Device", but that didn't work. The only "HID-Compliant Game Controller" I could find did not have a power management tab.

            I even went as far as adjusting the BIOS settings such that USB ports provide power even when the system is shut down. This did not work, either.

            In all cases, reWASD identifies that the controller is indeed connected. Whether or not the buttons work without requiring to disconnect and reconnect seems to fall on how Windows boots (sleep, fast boot, full boot, restart, etc).

            Comment


            • #7
              Doesn't seem to be there. I tried adjusting that mystery "USB Input Device", but that didn't work. The only "HID-Compliant Game Controller" I could find did not have a power management tab.
              Hm, strange. You could try to disconnect the controller — the tab will be refreshed — and connect it again to see the difference.
              To ensure that it is Switch Pro controller, you may check Hadrware IDs field, it should have the following VID:PID:

              Click image for larger version

Name:	41381eae25.png
Views:	334
Size:	61.9 KB
ID:	229426

              In all cases, reWASD identifies that the controller is indeed connected. Whether or not the buttons work without requiring to disconnect and reconnect seems to fall on how Windows boots (sleep, fast boot, full boot, restart, etc).
              Yes, because it is connected. But the port is sleeping, and so you do not get the respond from the buttons.

              Comment


              • #8

                Hardware ID almost matches your screenshot above.

                The issue persists.

                Comment


                • #9
                  Got it

                  Could you please specify which numbers you see? I assume you have different "REV" (revision), just curious which one.

                  Also, one more thing: once you switch to the View by connection (as I can see on your screenshot), please check the parent devices of USB Input Device — they also may have Power Management settings. Turn it off for all of them including USB Root Hub:

                  Click image for larger version

Name:	4fc11fb4b7.png
Views:	306
Size:	87.6 KB
ID:	229429

                  Comment


                  • #10
                    USB\VID_057E&PID_2009&REV_0210

                    Click image for larger version

Name:	Devices.png
Views:	307
Size:	39.1 KB
ID:	229433

                    Still having the issue.

                    Comment


                    • #11
                      That was our last idea unfortunately. This issue is related to the fast boot and specific behavior of the Nintendo controllers — and there is no way we could change it.

                      We will try to research this topic from our side, but I could not promise you anything at this point.

                      Comment


                      • #12
                        Maybe you could try a different port — which also has Power Management off?

                        Comment


                        • #13
                          Tried different ports. Front panel, rear/integrated, USB 2.0, 3.0. Issue still persists.

                          This is arguably a minor issue, and certainly seems to be Windows. reWASD is the best software solution I've found for using a Switch Pro with XInput globally on PC. (Steam Controller support only works in games launched through Steam. 8bitdo wireless adapter isn't without its flaws. Free software like BetterJoyForCemu doesn't fix the Switch Pro's poor stick circularity like reWASD can.)

                          Indeed the Switch Pro controller behaves quite erratically outside of its intended console, hence the need for additional software or hardware for use on PC. As far as software goes, reWASD is the best I've used so far!

                          Thank you for your support. I'll try to remember to update this thread if I somehow find a fix.

                          Comment


                          • #14
                            There might be one more way - to disable USB selective suspend. To do that open [Control Panel] > [Hardware and Sound] > [Power Options] > [Change plan settings] (of the currently selected power plan) > [Change advanced power settings]. Then find [USB Settings] > [USB selective suspend setting] and set it to [Disabled].

                            Click image for larger version

Name:	2022-01-08_0-28-34.png
Views:	299
Size:	22.4 KB
ID:	229442

                            PC restart might be necessary for the setting to apply.

                            Comment


                            • #15
                              I've attempted disabling USB selective suspension. Still cannot make input without unplugging and reconnecting after Windows startup.

                              Again, Windows and reWASD can still detect the controller. Just cannot make any inputs. It is quite bizarre, and I chalk it up to the finicky nature of the Switch Pro on non-Nintendo systems.

                              Comment

                              Working...
                              X