No announcement yet.

Switch Pro controller not working after shutdown.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hello! We have found a workaround that lets us reset the USB port to wake it from sleeping. Will add this fix to the upcoming release version, so stay tuned


    • #17
      Wonderful! I'm glad our conversation brought this to your attention for a future fix. I really appreciate your response to the issue.

      In the meantime, I just discovered another quick fix that's less cumbersome than physically unplugging and reconnecting the USB cable:

      Tap the sync button!

      This is how to manually turn OFF a Switch Pro controller. When wired to a PC, it disconnects and immediately reconnects so that Windows and/or reWASD can catch the inputs.

      I have two Switch Pro controllers. The one I bought at launch in 2017 requires something small to press the sync button, but the other is a 2018 revision that can be pressed with a bare finger (even though both have the same-looking recessed button).


      • #18
        Wow, thank you for sharing!

        The one I bought at launch in 2017 requires something small to press the sync button
        Seems I have a similar model — tiny button above


        • #19
          Looks like the issue is resolved in 6.1.0. Though it does take about a minute after a non-cold startup for the program to "grab" the controller. (Might take a while because of my system, it's overdue for a fresh reinstall of Windows).

          Waking up from SLEEP, it immediately works once the desktop appears. (I have the Switch Pro home LED set to briefly flash as an indication.)

          Thank you!


          • #20
            Thank you for letting us know. You are welcome.


            • #21
              I'm having this issue once again after updating to 6.2.1. reWASD SOMETIMES won't detect the controller upon fastboot for wake from sleep until I re-plug the controller or tap the sync button (still shows in Windows control panel).

              I rolled back to 6.1.0 a couple of weeks ago so I could see whether this is because of 6.2.1, or because of a Windows update.

              It looks like reverting to 6.1.0 fixed it. Maybe a combination of both Windows and reWASD updating.

              Otherwise, everything works perfectly! Excellent program, this is a very minor issue, and Switch Pro Controller is notoriously finicky when used outside of its intended platform.


              • #22

                From our side, the issue seems to be fixed. Maybe the reinstallation of reWASD did the trick. So would be great if you update to 6.2.1 to check it once again.


                • #23
                  Reinstalled 6.2.1

                  Seems to be working fine on Fastboot and waking from Sleep. It was rather inconsistent when I decided to revert a few weeks ago. I'll reply if it happens again.


                  • #24
                    Hope everything will be OK this time


                    • #25
                      Unfortunately, I can confirm that the issue has returned in 6.2.1: reWASD couldn't detect the controller even after a cold reboot until I reconnected the controller or tap the sync button. Minor inconvenience.

                      I'm rolling back to 6.1.0 for now.


                      • #26
                        Could you double-check if Allow the computer to turn off this device to save power is checked in Device Manager as you did earlier? I remind you that it should be turned off.


                        • #27
                          Ah, looks like that power management setting was somehow automatically re-enabled at some point.

                          That doesn't entirely explain why it was fine in 6.1, but was acting up again with 6.2, but it looks like the issue has once again been resolved.


                          • #28
                            Great! If you meet this issue again in 6.2.1 - let us know.