Announcement

Collapse
No announcement yet.

*URGENT* ReWASD Not Being Recognized By Game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • *URGENT* ReWASD Not Being Recognized By Game

    I have been using ReWASD for months now without problem. Recently, one of the updates have appears to complete screwed ReWASD. Windows still recognizes the controller fine. Using the built in Windows utility, button presses are registered fine. While in game, using the big Xbox button works fine (brings up the overlay). The ReWASD macros I have assigned to my Elite 2 that use Keyboard inputs (for example, spamming the W key on the keyboard, assigned to Elite 2 paddle) works fine. Normal button presses do not. No button assigned to standard functions work at all.

    I have uncovered a fix. Open the ReWASD interface and press the power button to disable to ReWASD profile, then turn it back on. This fixes the issue.

    This is a massive annoyance and shouldn't be like this. It worked fine for months. Please resolve this immediately.

  • #2
    Please take a screenshot of reWASD with your controller and the config you were using selected.

    We also need to know what the built-in Windows utility (joy.cpl) shows before and after you apply the config, and if your physical keyboard and mouse are selected at [Preferences > Input devices].

    We suggest using the [Apply to slot #] button instead of double-clicking the [Power] one, as [Power] only re-applies the previously applied config, and would ignore any changes made to the current one.

    Comment


    • #3
      Click image for larger version

Name:	image.png
Views:	1115
Size:	974.0 KB
ID:	239121
      I just got in game and pulled ReWASD over. The controller is connected, and the Windows utility registers all button presses, but the game doesn't seem to be aware of any of it. If I hit the "Off" button (bottom left) and turn it back on, it'll be fixed.

      Comment


      • #4
        Please send us 2 screenshots of how your controller is displayed in joy.cpl before and after applying the config.

        Also, try changing the virtual controller type and check if the problem persists.​

        Comment


        • #5
          Please see the attached images. They look identical. To obtain, I did the following:

          1. Reboot computer
          2. Run Apex Legends
          3. Attempt to use controller (doesn't work)
          4. Took Screenshot of joy.cpl + Xbox Accessories + ReWASD
          5. Used the POWER BUTTON on the bottom left of ReWASD to disable (and thereby return to native functionality)
          6. Waited 15 seconds
          7. Reenabled ReWASD using the POWER BUTTON (In case it isn't clear, I attached a screengrab of the power button)
          8. Controller works.

          This was not an issue before. This problem is new. I see others posting about this in your forums (namely someone complaining that Witcher 3 isn't being recognized) so it's unlikely an Apex specific issue.
          Attached Files

          Comment


          • #6
            We still need a screenshot of [joy.cpl] tool when reWASD remapping is disabled.

            And we still suggest you change the virtual controller to Xbox One via the [Magic Wand] icon in the middle.

            Comment


            • #7
              The controller is an Xbox Elite 2 controller (for context).
              Attached Files

              Comment


              • #8
                According to your description and screenshots, it looks like reWASD is working normally without any issues, yet some games require the virtual controller to be "re-plugged" to work with it.

                So far, it doesn't look like a reWASD issue.

                Could you clarify if you have these three options enabled in [Preferences > Tray Agent]:
                • Autostart the background agent;
                • Restore remap state on startup;
                • Restore the Slot chosen physically for Xbox Elite controllers​.

                Comment


                • #9
                  ​I've been playing with ReWASD for months without needs to do anything extra, simply turn on the controller and I'm off to the races. I recently nuked my PC (fresh Windows installation) which required me to download the latest ReWASD. That is when my issues began. The game likely had nothing to do with it, as I played the game within the same day, thus the same patch.

                  I have a few macros assigned to my paddles that press keyboard keys. When the game isn't registering any of my inputs, those macros still work, if that helps.
                  Attached Files

                  Comment


                  • #10
                    Could you specify the full version of Windows you are running and try setting our virtual controller as preferred in [joy.cpl] (via Advanced button).

                    To get the full Windows version, start the command prompt. The first line would be it (ex.: Microsoft Windows [Version 10.0.19045.3324]).

                    Comment


                    • #11
                      Microsoft Windows [Version 10.0.19045.3324]

                      I don't know what you are saying when you ask to have me set your virtual controller as preferred. I haven't previously had to change anything. I imported this configuration from the config upload section of your website after I uploaded before I nuked the PC. So it's literally what I was using before.

                      Comment


                      • #12
                        So far, we have only one assumption: the game finds and tries to use a controller that is no longer available. In other words, it tries to listen to inputs from your Xbox Elite 2 controller, while it is being replaced by our virtual Xbox 360.

                        Your config does not require the usage of a virtual controller, so we suggest you disable it. To do so, use [Native Mapping] for paddles that are remapped to controller buttons. Then click the [Magic Wand] icon in the middle and unselect all options.

                        Comment


                        • #13
                          I appreciate your replies in this thread, but I take offense to your suggestion. I purchased this software for a reason. This is brand new behavior and I have seen at least 1 other thread on this exact issue.


                          Hello everyone. Just the other day I came across a new - very odd - behaviour where The Witcher 3 wouldn't recognize my virtual controller using the Elite 2 anymore. This is very puzzling since it has worked for months now. Every other profile I have created still works as normal. I have tried every setting and solution I



                          I have been using this software for months. This just started. Prior to this, as is typical with all controllers I have every used with this game, when I press the power button (controller completely off) it connects, ReWASD pops up, and I am immediately able to control the game. It does not matter what controller I use, the moment it is connected, I am able to control the game. This new issue does not fix itself if I relaunch the game after closing it the first time. It is only resolved by turning off ReWASD and turning it back on.

                          I understand chasing something that may/may not be affecting a lot of people (if indeed it is just me and the Witcher 3 guy). I deserve to have my issue taken seriously. If you look at my config, I am using the W keyboard key on a paddle. I do indeed need the config.

                          I am trying to use my xbox one controller emulated as keyboard and mouse for COD Warzone. Every time I hit apply I get this message: "Games and Apps May Not Detect Virtual Controller Properly if There are Physical Ones Connected. It is better to unplug them to avoid conflicts." I hit ok but it does not work. The

                          Comment


                          • #14
                            It looks like a misunderstanding took place.

                            Your configuration does not require a virtual controller, meaning that your config, while slightly changed, can still be used and will produce the same result without any issues.
                            You can remap 3 of your paddles to controller buttons via [Native Mapping] and leave the [W] paddle as it is. This would ensure that no controller replacement would happen on your PC.

                            As for the issue itself, we have to make sure it is a reproducible reWASD issue and not the game`s, as your description suggests: when [joy.cpl] reacts to inputs from our virtual controller, meaning that reWASD is working correctly, and the game is the one with a problem for ignoring those inputs. So far we were unable to reproduce this issue, which means that it happens not due to reWASD or we don't have a full picture of it yet.

                            Comment

                            Working...
                            X