Announcement

Collapse
No announcement yet.

stick mapping mouse failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stick mapping mouse failure

    I map right stick to mouse to play FPS games. But sometimes one direction will just not work, but other 3 directions is ok, and if you pull the stick to other direction, then the direction didn't work will work again. It is fatal in FPS games, and I'm sure my controller has no issue. Another thing is that the stick maps the mouse. When the moving speed is very slow, the view movement is not smooth. Can you optimize this?

  • #2
    Hello,

    1. May I ask you to check it out the game with joy.cpl or https://html5gamepad.com/ tester. So, set devices group, check if the right stock mapped to a mouse is unmap. Apply config. Open joy.cpl (html5 tester) and check whether the stick is acting the way you described.


    2. If the speed is too slow I would add more sensitivity and increase the initial stick deflection for less leap.

    I would recommend you checking this blog post where all tips on how to tune a virtual stick on the mouse are collected.
    Don't worry! Be Happy!

    Comment


    • #3
      Originally Posted by Star-Lord View Post
      Hello,

      1. May I ask you to check it out the game with joy.cpl or https://html5gamepad.com/ tester. So, set devices group, check if the right stock mapped to a mouse is unmap. Apply config. Open joy.cpl (html5 tester) and check whether the stick is acting the way you described.


      2. If the speed is too slow I would add more sensitivity and increase the initial stick deflection for less leap.

      I would recommend you checking this blog post where all tips on how to tune a virtual stick on the mouse are collected.
      Yes,I tested it, My controller is OK. And the failure happens not usual. This problem will occur once about 1 or 2 minutes.
      Last edited by ventus; 24.05.2020, 08:56.

      Comment


      • #4
        Hey there!

        Please send me the config you are using. Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles
        I need the correspondent *.rewasd file.

        Comment


        • #5
          I would like to say, that the similar problem has already appeared before in version revasd 4.1.1 and has been fixed in version 411-0998. Now the mouse problem has returned from rewasd version 5.3.
          I think the problem arises when we change the shape of the motion curve. If it is default, then there is probably no mouse problem.
          Earlier problem:
          https://forum.rewasd.com/forum/rewas...use-stuttering

          Click image for larger version

Name:	moseproblem.jpg
Views:	278
Size:	150.2 KB
ID:	219609


          Originally Posted by ventus View Post
          Another thing is that the stick maps the mouse. When the moving speed is very slow, the view movement is not smooth. Can you optimize this?
          You can reduce in the game options the mouse sensitivity to a minimum, and to speed up mouse movement use the rewasd options. I think this is a problem with game engines. More abaut: https://www.reddit.com/r/pcgaming/co...ment_in_games/

          Attached Files

          Comment


          • #6
            Originally Posted by reWASDer View Post
            Hey there!

            Please send me the config you are using. Your congfigs are stored here: C:\Users\Public\Documents\reWASD\Profiles
            I need the correspondent *.rewasd file.
            here,thanks
            Attached Files

            Comment


            • #7
              Hello,

              ventus , we modified your config a bit, please try to reproduce the problem with this config.

              Wait for your feedback.

              Nirpo Please, specify details. There weren't any mouse changes since the 4.1.1. May I ask you to do some video where we can see the problem, like before and after you've changed the curve? What's the set sensitivity level? Did you try to lessen a bit?
              Attached Files
              Don't worry! Be Happy!

              Comment


              • #8
                Originally Posted by Nirpo View Post
                I would like to say, that the similar problem has already appeared before in version revasd 4.1.1 and has been fixed in version 411-0998. Now the mouse problem has returned from rewasd version 5.3.
                I think the problem arises when we change the shape of the motion curve. If it is default, then there is probably no mouse problem.
                Earlier problem:
                https://forum.rewasd.com/forum/rewas...use-stuttering

                Click image for larger version

Name:	moseproblem.jpg
Views:	278
Size:	150.2 KB
ID:	219609




                You can reduce in the game options the mouse sensitivity to a minimum, and to speed up mouse movement use the rewasd options. I think this is a problem with game engines. More abaut: https://www.reddit.com/r/pcgaming/co...ment_in_games/
                thanks,your solution is perfect! And I also remember the stick failure issue happened long time ago and then it's fixed but now it appears again.

                Comment


                • #9
                  Originally Posted by Star-Lord View Post
                  Hello,

                  ventus , we modified your config a bit, please try to reproduce the problem with this config.

                  Wait for your feedback.

                  Nirpo Please, specify details. There weren't any mouse changes since the 4.1.1. May I ask you to do some video where we can see the problem, like before and after you've changed the curve? What's the set sensitivity level? Did you try to lessen a bit?
                  It still will happen but I can't record it because it also need to record how my hand to push the stick... And it appears just one moment , it may disappear when I try to get my phone and touched other buttons.... but I think the reason maybe the curve option and vertical/horizon axis range...

                  Comment


                  • #10
                    Originally Posted by Star-Lord View Post
                    Hello,

                    ventus , we modified your config a bit, please try to reproduce the problem with this config.

                    Wait for your feedback.

                    Nirpo Please, specify details. There weren't any mouse changes since the 4.1.1. May I ask you to do some video where we can see the problem, like before and after you've changed the curve? What's the set sensitivity level? Did you try to lessen a bit?
                    Yes! It happens again and I made a video! Hope it can help you to solve it!
                    https://www.bilibili.com/video/BV1BZ4y1p7Wr/

                    Comment


                    • #11
                      Originally Posted by ventus View Post

                      Yes! It happens again and I made a video! Hope it can help you to solve it!
                      https://www.bilibili.com/video/BV1BZ4y1p7Wr/
                      On this ventus vido we can to see Y-axis lock failure, i noticed the same problem with my config.




                      Mouse movement sometimes locks when we pass the x or y axis.
                      In this situation, despite stick inclination, mouse movement can not pass through the axis, but it can move along the axis. To unlock the movement of the mouse, you have to stop stick inclination.

                      Mouse movement locks only when we choose Custom Response and we will change the curve.
                      If we change: vertical and horizontal axis range to zero. and will reduce dead zone, the effect can be appear more often.
                      Mouse movement locks usually appears during slow opposing movements with a small deflection of the stick.
                      To notice this issues, you need a little patience, because, for the most part of the time, the movement of mouse is good.

                      Times of the mouse movement locks on the x and y axis on the following example video:
                      01:08 - 01:17 X-axis lock failure
                      02:40 - 02:49 Y-axis lock failure
                      03:24 - 03:36 X-axis lock failure
                      04:02 - 04:16 X-axis lock failure
                      05:26 - 05:40 Y-axis lock failure
                      05:58 - 06:09 Y-axis lock failure
                      06:38 - 06:49 X-axis lock failure
                      06:59 - 07:10 Y-axis lock failure
                      https://streamable.com/3r7l8s



                      Click image for larger version

Name:	mouseaxisfailure.jpg
Views:	269
Size:	298.4 KB
ID:	219625


                      MouseAxisLockFailure.rewasd

                      Comment


                      • #12
                        Hello,
                        Thank you for your videos and detailed explanations! We will investigate the problem and back with updates.

                        Don't worry! Be Happy!

                        Comment


                        • #13
                          Hey here guys!

                          Yep, the issue is confirmed. It is much harder to reproduce it than back in 4.1.1 but seems I see the steps.
                          We will try to fix it in the next version that is coming in the middle of summer. Stay tuned!

                          Comment


                          • #14
                            Originally Posted by reWASDer View Post
                            Hey here guys!

                            Yep, the issue is confirmed. It is much harder to reproduce it than back in 4.1.1 but seems I see the steps.
                            We will try to fix it in the next version that is coming in the middle of summer. Stay tuned!
                            And Can you give us a more smooth custom curve instead of the 4 point line?

                            Comment


                            • #15
                              Yes, it sounds possible. Do you need more points for stick mapped to mouse?

                              What about 8 points? Will it be enough?

                              Comment

                              Working...
                              X