Announcement

Collapse
No announcement yet.

How to add modifier function to Xbox Elite 2 controller?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to add modifier function to Xbox Elite 2 controller?

    I'm currently trying to add a modifier to one of the back paddles of the Elite 2 controller.

    What I want to happen is, when I use the left control stick it works as normal, but when I hold down the paddle, I want the left control stick to have a smaller maximum value, for walking or slow aiming in games.

    Currently, I have it so when I hold down the paddle it shifts to another layer, which works fine. But I'm not entirely sure how to actually apply a deflection or reduction of the control stick value for a physical controller. I know you can do it for the virtual controller, but not how to do it for the physical one.

    Thanks!

  • #2
    Hello!

    Please open the Advanced settings of the Left Stick while you are in Shift Layer 1 and check the Response curve. You need to lower the upper point and adjust the other points to make the movement smooth. It will be something like this:

    Click image for larger version

Name:	e4e828f11b.png
Views:	321
Size:	57.0 KB
ID:	231172

    Comment


    • #3
      This doesn't help, this just seems to affect how smooth the movement is once moving the stick. I'm talking about reducing the maximum value. I can't edit that final value on that curve to be lower than the default. Notice in the attached image from my settings how I can't change the lowest and highest point. I'm looking for something like the red line that I drew.

      Click image for larger version  Name:	Example curve.png Views:	60 Size:	17.3 KB ID:	231174

      Comment


      • #4
        You have four points there — and only those ones could be moved. However, you can move them by both axes. Here is how to get the same curve: https://recordit.co/M5epe77hlm

        Comment


        • #5
          You're still not getting it I don't think...

          I know you can move them by both axes, but that isn't the issue. The issue is I want the maximum possible value, to be reduced.
          If I push the control stick all the way forward, the resulting output value is 1.
          If I push the control stick all the way forward modified, the maximum possible value should be less than that. Like 0.5 if I want 50% of the total output.

          All moving the points forward does, is change how far forward I have to push the stick to get it to output 1.

          Here is my current 'curve':



          But all this does is result in this:



          What I want is shown quite clearly in Dolphin, where the gray dot shows the point where the analog stick is, but the red dot shows the actual output.



          This use is quite important in things like Super Smash Bros. Melee, where changing to a lower max value allows for walking and certain tilts and directionals.

          Comment


          • #6
            This is the forum post that solves it using the virtual controller, but this user is using the keyboard.

            I tried searching the forums but couldn't find anything. Is there a way to create a KB keybind toggle to "slow walk"? I'd like to simulate the PS4 left stick option to walk slow when I use my keyboard WASD movement keys by toggling another KB keybind to turn walking slow on/off. Is this possible?

            Comment


            • #7
              Hello!
              Please send me the config you are using.
              Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles I need the correspondent *.rewasd file.

              Comment


              • #8
                Here, I attached it. The modifier should be on layer 4.
                Attached Files

                Comment


                • #9
                  Thank you.
                  I redid the curve in layer 4 as suggested by reWASDer and now full left stick deflection deflects the virtual left stick by 50%. The value in the tester is 0.5.
                  Check it out for yourself.
                  Attached Files

                  Comment


                  • #10
                    Odd. I still get 1. All this curve does is make it reach the max value with the control stick half pushed forward.

                    Click image for larger version

Name:	Example curve 3.png
Views:	262
Size:	12.7 KB
ID:	231184

                    I assume this is the curve you made?
                    I don't see any other changes made to the config file.

                    Comment


                    • #11
                      It looks like the curve was not saved after editing. This is a known issue with displaying a curve on a layer other than the main layer. We will fix this in version 6.1.1.
                      Try to make such a curve in layer 4, then click Apply. Open the tester, jump to layer 4 with your paddle and test the stick.

                      Comment


                      • #12
                        And this is what I keep trying to tell you and you still aren't listening. I've done this 4 times.

                        This does NOT solve the issue. This just makes it act that way, up until you fully press the stick, at which point it jumps to the maximum value.

                        Click image for larger version

Name:	Example curve 4.png
Views:	257
Size:	15.3 KB
ID:	231187

                        Look see below, it works perfectly, and then as soon as I fully press the stick forward, it jumps from 0.5 to 1. I don't want it to do this. I want it so when I'm pressing the shift layer button, it's literally impossible for the control stick to output 1 in any direction whatsoever. Look at my dolphin post example above to see what I mean.

                        If you put the curve like this yourself, and fully press the control stick forward, you'll get 1.

                        Comment


                        • #13
                          You need to look here, this is the problem. I need to be able to change the final point of the curve to reduce the maximum. It doesn't matter where I put these 4 points on the curve, it will never solve the issue.

                          Click image for larger version

Name:	Example curve 4b.png
Views:	248
Size:	17.5 KB
ID:	231189

                          This here is more in line with what I'm referring to, which sets the initial minimum (dead zone) and maximum (limit) value, of the control stick. But this only works for the virtual controller.

                          Click image for larger version

Name:	Virtual example.png
Views:	234
Size:	69.4 KB
ID:	231190

                          Comment


                          • #14
                            I am unable to reproduce the behavior you describe.
                            With the specified curve, in the 4th layer, the stick does not move beyond the set limit even with full deflection.
                            You can verify this by watching this video.

                            Perhaps you are missing something?
                            Can you record a similar video with a test of this curve?

                            Comment


                            • #15


                              Hmm not sure what...
                              Sorry this has been bugging me for a while.

                              Comment

                              Working...
                              X