No announcement yet.

No Mouse Movements

  • Filter
  • Time
  • Show
Clear All
new posts

  • No Mouse Movements

    Hello there! So, as the title says, I've had an issue getting my mouse (which I mapped to the right joystick of an Xbox controller) to look around in-game (Batman Arkham Knight). The weird part is that the rest of the mouse functions work. Left-click, which I mapped to right trigger, and right-click, which I mapped to left trigger, worked perfectly fine. I tried to solve the issue using the following trouble-shooting methods, unfortunately, to no avail:

    1) Re-initializing both my keyboard and mouse numerous times.
    2) Clearing the data via preferences.
    3) Uninstalling and reinstalling reWASD.

    Something I would like to note is that my keyboard shows up as a Mouse and Keyboard at the bottom of the screen (which you can see in the provided screenshots), and all of my attempts to change that via re-initialization have been futile. Also, whenever my mouse locks due to double input (which, according to videos on Youtube, is supposed to happen, so I guess I'm somewhat on the right track), the left windows button does not unlock my mouse; it just pulls up my taskbar.

    I have attached all relevant screenshots of my configuration to this post. However, if you require more to provide more informative feedback, please feel free to ask.

    Thank you

    (Addendum: I have a license and can provide proof if necessary.)​
    Attached Files

  • #2
    Please send me the config you are using. Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles
    I need the correspondent *.rewasd file.​


    • #3
      Is this what you're asking for?
      Attached Files


      • #4
        The mouse did not return to native behavior because the special Shift layer responsible for this was not properly configured.
        I fixed it. Now when you press the Left Win button, your devices will return to native behavior, and when you press it again, it will again become a virtual controller.
        Try the updated config.

        If in game, after applying the config, the mouse still won't let you control the camera, check a couple of things:
        1. If the game allows you to select the input method in the settings, make sure that the controller is selected, not kb&m
        2. Open the gamepad tester. Apply the config using the "Apply to slot" button and control the mouse and keyboard. Is the virtual controller on the site fully responsive?
        3. If everything is fine with the first two points, try changing the type of virtual controller to Xbox 360, reapply the config and restart the game.​
        Attached Files


        • #5
          It works now! Thank you for the responses on such short notice!


          • #6
            We are always happy to help!