No announcement yet.

PC to Xbox One using Xcloud

  • Filter
  • Time
  • Show
Clear All
new posts

  • PC to Xbox One using Xcloud

    Hi there,

    I am trying to play my Xbox One using rewasd through my PC. I was once able to control my Xbox with my keyboard and mouse however this time it is not working. I'm using the remote play feature and it is recognizing my keyboard and mouse as a controller but it's still not working.

    Can anyone help?

  • #2
    Most common issues in this case are:
    • Wrong mouse and keyboard are being remapped
      Use device detection mode to check if you are remapping correct devices.
    • Incorrect initialization of your mouse and keyboard
      Check case #24 here for a solution.
    • Another controller is connected to your PC
      Disconnecting or adding these controllers to the group with your mouse and keyboard would be a solution.
    • Incomplete or wrong profile/config used
      We suggest using a build-in [xCloud] profile. If you don't have it, you can get it from our Community page.
    Once reWASD is properly configured, we suggest testing it with [joy.cpl] tool (type that into Windows Start Menu) or at Gamepad Tester site.


    • #3
      Thanks for the prompt response.

      - Wrong mouse and keyboard are being remapped / Detection

      I am using the same mouse and keyboard configuration that I used to play my PlayStation. Also, when I use the detection method it is definitely detecting my devices.

      - Incomplete or wrong profile/config used
      I am using the built-in xcloud config. Same configuration that I use last time and it worked.


      • #4
        And what about other cases and testing results?


        • #5
          Hey man,

          Sorry for late reply.

          I've done all steps but still I'm having the same problem


          • #6
            So, Xbox game pass seems to recognize Rewasd as a controller as well yet none of the controls work. joy.cpl also recognises the control.

            I don't understand how I can have it working one minute and now it's not allowing me at all.

            I know I am missing something but can't figure it out?


            • #7
              Hi. Please send us a screenshot of the full reWASD window with your mappings.


              • #8
                Thank you for the reply!
                Attached Files


                • #9
                  Unfortunately, nothing is visible in the screenshot you sent.
                  Please send a correct copy of the screenshot.​


                  • #10
                    How about this? Click image for larger version

Name:	EFDF02415C704F7F9C37966176EE4C78.jpg
Views:	120
Size:	4.3 KB
ID:	239246


                    • #11
                      Your screenshot looks something like this, and nothing is visible on it.

                      Please make the reWASD window a little smaller, then take a screenshot by clicking on the active reWASD window and using the shortcut [Alt]+[PrScr] and [CTRL]+[V].​

                      Click image for larger version  Name:	image.png Views:	1 Size:	36.3 KB ID:	239248


                      • #12
                        We need to see whether your devices are grouped correctly and to which group of devices the config is applied.
                        Please send us a screenshot.​


                        • #13
                          Click image for larger version

Name:	Screenshot 2023-09-12 205012.png
Views:	141
Size:	360.4 KB
ID:	239252 My apologies, hopefully you can view this better.


                          • #14
                            Please apply the config and check if it works correctly in the tester:


                            • #15
                              I've tried connecting my Bluetooth game sir to my PC but it's not being recognized. However, I started remote play to my PS5 and that is working like normal.